Friendica
Mara
Mara

Mara

Mara@hachyderm.io

Mara

Mara@hachyderm.io
Rust dev, Electronics engineer, Author, Rust library team lead, ADHD, Polyamorous, Lesbian, She/Her
ActivityPub
2025-11-19 15:30:33 2025-11-19 12:00:24 2025-11-19 07:33:07 9228058

Mara
Mara
mastodon - Link to source

Mara

1 week ago • •

Mara

1 week ago • •


#rustlang hot take: We should rename .unwrap() to .or_panic(). (And .expect() to .or_panic_with().) "Unwrap" is a terrible name for the panicking function, especially since we also have things like .unwrap_or() and .unwrap_or_default() which never panic.
#RustLang
  •  Languages
  •  Search Text
  •  Share via ...

reshared this

Federico Mena Quintero reshared this.

⇧